-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Artwork
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (29) . 

WDT - Web Developer Tools

   2.6.6  

Other GNOME Stuff

Score 79%
WDT - Web Developer Tools
zoom


WDT - Web Developer Tools
zoom


WDT - Web Developer Tools
zoom


Minimum required   GTK 2.x
Downloads:  13619
Submitted:  Sep 3 2010
Updated:  Jul 7 2011

Description:

WDT - Web Developer Tools is a suite of useful tools for web developers

Patch for UNITY available, statusicon replaced with appindicator

Download the archive, extract it and move the webdeveloper.py file to /usr/share/wdt and replace the current one.

Deb packaging for now in Ubuntu 11.04 is not available, the old version working well, the patch will add you the appindicator support, because the statusicon support has been removed from 11.04.

Non UNITY users can use the old versions.

Notice: backup you current file before applying the patch for sure.



WDT on twitter: http://twitter.com/wdttools


Depends: python (>=2.4), python-gtk2, python-webkit, python-imaging, python-feedparser, python-notify, optipng (>= 0.6.2.1), advancecomp (>= 1.15),wget,mysql-client, lftp, gzip, bzip2,python-gmenu


In the repository updates are available later(cca. 1 hour)




from Version 2.0.4 with PPA

for UBUNTU users:
sudo add-apt-repository ppa:petrakis/wdt-main

The WDT link on Launchpad: https://launchpad.net/~petrakis/+archive/wdt-main



If you have problems, read first the news & updates section inside the application

What is included?
Task Manager
Dean Edwards Javascript Compressor
JSMin
Css Minifier
Css Type Set Generator
Css Button Generator
Cool Button Generator
RGB / HEX Color chart
VTE Terminal
WYSIWYG HTML 5 Editor
Website Analyzer (Yslow+PageSpeed)
3 x online W3C validators
ScriptBook
Customizable menu for other apps
and more ...




Changelog:

version 2.6.6 FontFace Comparer,remove wysiwyg editor
version 2.6.5 bug fixes + "Show/hide Tabs" function added
version 2.6.4. bug fix in customization, added css gradient generator, removed css3 generator, redesigned news & updates section
version 2.6.3 changed CSS Type + HTML 5 db support added
version 2.6.2 Sitemap/Flowchart generator
version 2.6.1 modified chart generator
version 2.6.0 scheduled update
version 2.5.9 chart generator
version 2.5.8 bug fix for CSS sprites menu entry
version 2.5.7 Css Sprites Generator
version 2.5.6 added Drawter and Iconfinder
version 2.5.5 xml to json
version 2.5.4 scheduled update
version 2.5.3 bug fix, goo.gl added
version 2.5.2 Css speech bubbles
version 2.5.1 JS Beautifier
version 2.5.0 GUI for Apps and Places + functions upgrade
version 2.4.9 extra menus added
version 2.4.8 error relaese
version 2.4.7-2 merged config files
version 2.4.6 Code Syntax Highlight
version 2.4.5 minor modifications & improvements
version 2.4.4 cleaning release
version 2.4.3 fix release
version 4.2.2-1 single entry editing
version 2.4.1 bug fix release (customization section)
version 2.4.0 fixed cron issue
version 2.3.9 full customization
version 2.3.8 Gmail & Web Monitor support via cron
version 2.3.7 update release
version 2.3.6-1 bug fix
version 2.3.6 customizations support added
version 2.3.5-1 Cron job bug fix
Version 2.3.5 FTP Backup, Mysql Backup
Version 2.3.4 layout changes, google translator
Version 2.3.3 gmail fix, screen-shots tool
Version 2.3.2 bug fix release
Version 2.3.1 updated website monitoring
Version 2.3.0 Multiple gmail Support
Version 2.2.9 Websites monitor
Version 2.2.8 Update content changed + tooltips in bottom panel
Version 2.2.7 Hardcoded and started Ajax Examples
Version 2.2.6 Mass Image reflection
Version 2.2.5 Post card generator & sender
Version 2.2.4 Gmail error handling
Version 2.2.3 Direct gmail sender
Version 2.2.2 New wysiwyg editor
Version 2.2.1 3 in 1 image tool
Version 2.2.0 Mass Image Compressor
Version 2.1.9 Css editor layout changed
Version 2.1.8 reduced wbkit views + minor code fixes
Version 2.1.7 Integrated Gmail
Version 2.1.6 Freezing fix release
Version 2.1.5 Changed CSS Editor to CSS# Generator
Version 2.1.4 Critical fix, removed javascript combiner, added CSS Desk
Version 2.1.3 Ascii/Hex/Binary/Integer/Base64 Encoder/Decoder
Version 2.1.2 Javascript debugger, javascript combiner, python-psyco fix
Version 2.1.1 fixed layout, changed CSS type set, Added CSS property table
Version 2.1.0 bug fix, image processing (watermarking and resizing)
Version 2.0.9 GUI for settings created, syntax highlight editor added
version 2.0.8 Manual & Tutorials, modified sections by groups, application can start from terminal with command wdt
Version 2.0.7 Webkit Browser + Inspector
Version 2.0.6 Changed path for settings file , cleaned up CSS Editor to fit low resolution screens
Version 2.0.5 CSS Visual Editor
Version 2.0.4 WDT on launchpad
Version 2.0.3 Fixed space problem if the css code was generated (thanks to yestaro)
Version 2.0.2 All screen resolution support, enable-disable task manager, Yslow + Page Speed Analyzer

Version 2.0.1 Task Manager with usage of local storage, restart button for application self restarting
Version 1.9-9 rewrited system tray, cleaning up, JSMin minifier
Version 1.9-8 system tray
Version 1.9-7 Added scriptbook

Version 1.9.6
Customizable menu for applications integrated, see more in news & update section inside the app.

Version 1.9-5
small bug fix release

Version 1.9-4
Added CSS Type Set Generator
Added News & Updates section , so you can be informed about latest releases and upcoming features

Version 1.9-0
In cool button generator added an option for mass buttons creating. You need to select directory, where your images are located, open the dir and that's all. Your button are done.(see in screenshot 3)

Source contains instruction for installing. Read it first.


About releases here will be only short info. For detailed changes and upcoming features you can be informed from internal section inside the application.

For Arch Users
if the release in yours location is outdated, use the source




LicenseGPL
Ubuntu
other(Source)
Arch(AUR)
(CZ-PACK (json version from v 2.5.5))
(Unity Patch)
Send to a friend
Subscribe
Other  Artwork  from petrakis
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7 

-

 Not working in Maverick!

 
 by Brutus180 on: Sep 23 2010
 
Score 50%

After updating to this newest version it no longer works. It starts and is functional for around 10 seconds; then it freezes. This is the output when I run it from the terminal:

Warning(optionsfile.cc:22): Load: Could not open file
No bp log location saved, using default.
[000:024] Browser XEmbed support present: 1
[000:024] Browser toolkit is Gtk2.
[000:024] Using Gtk2 toolkit
** (webdeveloper.py:21889): DEBUG: NP_Initialize
** (webdeveloper.py:21889): DEBUG: NP_Initialize succeeded
[000:328] Warning(optionsfile.cc:22): Load: Could not open file
[000:328] Warning(optionsfile.cc:22): Load: Could not open file
[000:328] No bp log location saved, using default.
[000:328] Browser XEmbed support present: 1
[000:328] Browser toolkit is Gtk2.
[000:328] Using Gtk2 toolkit
** (webdeveloper.py:21889): DEBUG: NP_Initialize
** (webdeveloper.py:21889): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:21889): DEBUG: NP_Initialize
** (webdeveloper.py:21889): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:21889): DEBUG: NP_Initialize
** (webdeveloper.py:21889): DEBUG: NP_Initialize succeeded
** Message: console message: http://jsbin.com/js/2.1.2/jsbin.js @174: jsbin init test

java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9) (6b20-1.9-0ubuntu1)
OpenJDK Server VM (build 17.0-b16, mixed mode)

Is there something I can do to make this great app work again?


Reply to this

-

 Re: Not working in Maverick!

 
 by petrakis on: Sep 24 2010
 
Score 50%

The debug messages are for webkit, and this type of message is normal. For the java message , I am using Sun's java, for this reason I cannot tell you if they is an problem. Secondly, until the final release of Maverick, the all full test are made for Lucid. My suggestion you need to have installed latest webkit, pywebkitgtk and sun's java installed.


Reply to this

-

 Re: Not working in Maverick!

 
 by petrakis on: Sep 24 2010
 
Score 50%

In new version has been included only some sh scripts, so probably something happened with your system (Maverick)


Reply to this

-

 Re: Not working in Maverick!

 
 by petrakis on: Sep 26 2010
 
Score 50%

the problem has been fixed in v 2.1.4


Reply to this

-

 Re: Re: Not working in Maverick!

 
 by Brutus180 on: Sep 26 2010
 
Score 50%

Hi. I upgraded through your repository and experienced the same problem. I did a complete removal through Synaptic and deleted the wdt file in .config. After that I installed from source and it wouldn't run at all.

For the repository version the terminal output is the same with this new stuff on the bottom:

sh: getcwd() failed: No such file or directory
Error occurred during initialization of VM
java.lang.Error: Properties init: Could not determine current working directory.
at java.lang.System.initProperties(Native Method)
at java.lang.System.initializeSystemClass(System.java:1069)


Installing from source I get this message after attempting to run it:


Traceback (most recent call last):
File "./webdeveloper.py", line 3160, in <module>
NotebookExample()
File "./webdeveloper.py", line 1931, in __init__
self.window.set_icon_from_file(os.path.join(self.iconpath, "wdt.png"))
glib.GError: Failed to open file '/usr/share/wdt/icons/wdt.png': No such file or directory


It is not just the icon it can't find, but everything in /usr/share/wdt/wdt.
After correcting the scripts to read the proper files, it then acted as the repository version, it started but stopped after a few seconds and then freezes, needing a force quit. On a side note, it also doesn't respect AWN dock as a panel and goes under it for some reason.

Anyway, I have all the required packages, but I have OpenJDK and Sun Java installed for various reasons. If the Java is the problem, can I force it to use one or the other? I get nothing by entering "wdt --help" or "man wdt", so I'm a bit in the dark since I can't read the documentation within the program.


Reply to this

-

 Re: Re: Re: Not working in Maverick!

 
 by petrakis on: Sep 26 2010
 
Score 50%

In new version I have already removed the problematic part with java package. In version 2.1.4 the java package has been removed. If you are running the wdt on Maverick, for now I cannot help you. Today I will start testing on Maverick.


Reply to this

-

 Re: Re: Re: Not working in Maverick!

 
 by petrakis on: Sep 26 2010
 
Score 50%

I have installed beta version of Maverick and after the clean install the first app was wdt. Without needing to install any other package wdt working fine. The only problem was with installation , with software center, but using command sudo dpkg -i wdt_2.1.4~ppa0_all.deb , the installation has been finished correctly. All instances of wdt are working properly


Reply to this

-

 Re: Re: Re: Re: Not working in Maverick!

 
 by Brutus180 on: Sep 26 2010
 
Score 50%

I have confirmed that WDT does work on a vanilla install of Maverick using Virtual Box.

First I fully updated Maverick and installed WDT through your repo and it worked.

I then installed OpenJRE and it worked. Then I installed Sun Java on top of that and it worked.

But it still does not work on my current desktop. Is there any way to find out why or should I just give up? (Thanks for your help btw.)


Reply to this

-
.

 Re: Re: Re: Re: Not working in Maverick!

 
 by Brutus180 on: Sep 27 2010
 
Score 50%

It now works. I just did an apt update and the newest pywebkit in your repository seems to have fixed whatever the problem was. Your version seems to be the same as in the webkit repo, so I'm pretty confused. I can't tell what the problem was because I have the webkit repo enabled and updated (I use other programs that depend on it), but apparently this was in some way all my fault and not yours at all. Anyway, thanks for the great program!


Reply to this

-
.

 No work with Lucid.

 
 by J4X0R on: Sep 26 2010
 
Score 50%
J4X0RJ4X0R
School/Home
-
Jake Amey 15

School/Home
United States of America, Sterling Heights, MI
Last visit May 29 2013
0 Friends
7 Groups

More info
Send a message
Add as friend
Other contents
--

It seems I am getting the same problem with in Lucid. Starts up and works fine for about 10 seconds. Then a hard freeze requiring a force quit.

Hope it gets fixed soon. Seems like a very useful program.


Reply to this

-

 Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

I am working on Lucid without problems. Please try to run it over the terminal and post any error message


Reply to this

-

 Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

I found it. In some situations the javascript combiner which uses java file produces memory overhead. I will remove it and upload new fixed version.


Reply to this

-

 Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

Fixed, the javascript combiner, which produces freezing and memory overhead has been removed


Reply to this

-
.

 Re: Re: No work with Lucid.

 
 by J4X0R on: Sep 26 2010
 
Score 50%
J4X0RJ4X0R
School/Home
-
Jake Amey 15

School/Home
United States of America, Sterling Heights, MI
Last visit May 29 2013
0 Friends
7 Groups

More info
Send a message
Add as friend
Other contents
--

No dice for me, Thanks for trying to fix the problem last night. I just uninstalled and reinstalled via your supplied Debi package.

Ran from terminal and my results are posted below.

jake@HpTouchSmartTm2:~$ wdt
** Message: console message: file:///usr/share/wdt/task/js/com.js @23: SECURITY_ERR: DOM Exception 18: An attempt was made to break through the security policy of the user agent.


** (webdeveloper.py:32626): WARNING **: Invalid borders specified for theme pixmap:
/home/jake/.themes/BlackFate/gtk-2.0/shadows/frame1.png,
borders don't fit within the image

** (webdeveloper.py:32626): WARNING **: invalid source position for vertical gradient

** (webdeveloper.py:32626): WARNING **: invalid source position for vertical gradient

** (webdeveloper.py:32626): WARNING **: invalid source position for vertical gradient

** (webdeveloper.py:32626): WARNING **: invalid source position for vertical gradient
** Message: console message: file:///usr/share/wdt/cssdesk/plugins.js @1735: SECURITY_ERR: DOM Exception 18: An attempt was made to break through the security policy of the user agent.

** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: file:///usr/share/wdt/cssdesk/desk.js @1: TypeError: Result of expression '$frame[0].contentWindow.document' [undefined] is not an object.

** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** (webdeveloper.py:32626): DEBUG: NP_Initialize
** (webdeveloper.py:32626): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:32626): DEBUG: NP_Initialize
** (webdeveloper.py:32626): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:32626): DEBUG: NP_Initialize
** (webdeveloper.py:32626): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:32626): DEBUG: NP_Initialize
** (webdeveloper.py:32626): DEBUG: NP_Initialize succeeded
** Message: console message: http://jsbin.com/js/2.1.2/jsbin.js @174: jsbin init test

java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.1) (6b18-1.8.1-0ubuntu1)
OpenJDK Server VM (build 16.0-b13, mixed mode)
/usr/bin/wdt: line 2: 32626 Killed python /usr/share/wdt/webdeveloper.py
jake@HpTouchSmartTm2:~$


Reply to this

-

 Re: Re: Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

It looks for webkit problem. Try to update to latest webkit and pywebkitgtk package from PPA webkit team


Reply to this

-

 Re: Re: Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

I have added into wdt ppa webkit and pywebkitgtk packages, for quick update


Reply to this

-

 Re: Re: Re: No work with Lucid.

 
 by petrakis on: Sep 26 2010
 
Score 50%

I have installed beta version of Maverick and after the clean install the first app was wdt. Without needing to install any other package wdt working fine. The only problem was with installation , with software center, but using command sudo dpkg -i wdt_2.1.4~ppa0_all.deb , the installation has been finished correctly. All instances of wdt are working properly


Reply to this

-

 Great app !

 
 by allietux on: Sep 26 2010
 
Score 50%

Simple , clean and useful. Thank you so much


Reply to this

-
.

 Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

Hi... same issue in Karmic... works fine 10 o maybe 15 seconds and freeze, and no response any more... kill process is the unique way... jeje... xD... I will try the clean installation...

But, I think that we have a serious problem with Software Center or with the PPA... I hope than the problem solve... xD...This tool is terrific!!...


NOTE: Sorry for my english... I speak spanish....


Tequilas Team - Made in Mexico
Reply to this

-

 Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

If you are using 32Bit Karmic, install python-psyco package first. About software center I don't know, but for karmic and jaunty the packages in PPA are just copied from Lucid, so maybe this can be a problem. About freezing I am loking for it, but my recommendation is install the python-psyco package


Reply to this

-
.

 Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

Hi... thanks for you respose... but I have already install the python-psyco package... and the problem continue...

Any idea??


Reply to this

-

 Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

can you post a output if you run it from terminal?


Reply to this

-

 Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

Or can you tell me in which section you are if freezing is starting?


Reply to this

-
.

 Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

Ok... first the output of terminal is:

Quote:

** Message: useQuirks: 0 / 0 / (10 times)
** Message: useQuirks: 0 / 0 / jsbin.com (3 times)
** Message: useQuirks: 0 / 0 /
** Message: useQuirks: 0 / 1 / google.com (3 times)
** Message: useQuirks: 0 / 0 /
** Message: useQuirks: 0 / 0 / www.visualjquery.com (3 times)
** Message: useQuirks: 0 / 0 /

** (webdeveloper.py:7014): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed (7 times)

** Message: useQuirks: 0 / 0 / (20 times)
** Message: useQuirks: 0 / 0 / code.jquery.com (2 times)
** Message: useQuirks: 0 / 0 / ajax.googleapis.com (2 times)
** Message: useQuirks: 0 / 0 / (45 times)
** Message: useQuirks: 0 / 1 / www.google.com
** Message: useQuirks: 0 / 0 / jsbin.com (4 times)
** Message: useQuirks: 0 / 0 / www.visualjquery.com (4 times)
** Message: useQuirks: 0 / 0 / jsbin.com (4 times)
** Message: useQuirks: 0 / 0 / (43 times)
** Message: useQuirks: 0 / 0 / www.google.com.mx
** Message: useQuirks: 0 / 0 / (6 times)
** Message: useQuirks: 0 / 0 / forbind.net (2 times)
** Message: useQuirks: 0 / 0 / jsbin.com (4 times)
** Message: useQuirks: 0 / 0 / (12 times)
** Message: useQuirks: 0 / 0 / www.google.com.mx (6 times)
** Message: useQuirks: 0 / 0 / www.visualjquery.com (9 times)
** Message: useQuirks: 0 / 0 / jsbin.com (4 times)
** (webdeveloper.py:7014): DEBUG: NP_Initialize
** (webdeveloper.py:7014): DEBUG: NP_Initialize succeeded
Warning(optionsfile.cc:22): Load: Could not open file
No bp log location saved, using default.
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:000] Using Gtk2 toolkit
** (webdeveloper.py:7014): DEBUG: NP_Initialize
** (webdeveloper.py:7014): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:7014): DEBUG: NP_Initialize
** (webdeveloper.py:7014): DEBUG: NP_Initialize succeeded
[000:015] Warning(optionsfile.cc:22): Load: Could not open file
[000:015] Warning(optionsfile.cc:22): Load: Could not open file
[000:015] No bp log location saved, using default.
[000:015] Browser XEmbed support present: 1
[000:015] Browser toolkit is Gtk2.
[000:015] Using Gtk2 toolkit
** (webdeveloper.py:7014): DEBUG: NP_Initialize
** (webdeveloper.py:7014): DEBUG: NP_Initialize succeeded
** Message: useQuirks: 0 / 0 / jsbin.com (2 times)
** Message: useQuirks: 0 / 0 /
** Message: useQuirks: 0 / 0 / jsbin.com (6 times)
** Message: useQuirks: 0 / 0 /
** Message: useQuirks: 0 / 0 / jsbin.com (5 times)
** Message: console message: http://jsbin.com/js/2.1.2/jsbin.js @174: jsbin init test

** Message: useQuirks: 0 / 0 / www.google-analytics.com (2 times)
** Message: useQuirks: 0 / 0 /
** Message: useQuirks: 0 / 0 / www.google.com.mx (4 times)
** Message: useQuirks: 0 / 0 / clients1.google.com.mx (2 times)
** Message: useQuirks: 0 / 0 / www.google.com.mx (2 times)
** Message: useQuirks: 0 / 0 / jsbin.com
** Message: useQuirks: 0 / 0 / www.google-analytics.com (2 times)
** Message: useQuirks: 0 / 0 / jsbin.com (4 times)
** Message: useQuirks: 0 / 0 / forbind.net (2 times)
** Message: useQuirks: 0 / 0 / www.visualjquery.com (4 times)


Repeated consecutive lines were summarized as:

line (n times)

Second any section freeze, include if open wdt and no click in any section the application freese any way...

Thanks for the response


Tequilas Team - Made in Mexico!
Reply to this

-

 Re: Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

Looks without problem for Karmic. i have in Lucid this output:
** (webdeveloper.py:8238): DEBUG: NP_Initialize
** (webdeveloper.py:8238): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:8238): DEBUG: NP_Initialize
** (webdeveloper.py:8238): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:8238): DEBUG: NP_Initialize
** (webdeveloper.py:8238): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:8238): DEBUG: NP_Initialize
** (webdeveloper.py:8238): DEBUG: NP_Initialize succeeded
** Message: console message: http://jsbin.com/js/2.1.2/jsbin.js @174: jsbin init test


In old webkit my output was similar like your's. But theese messages are OK. Can you tell me from which version of wdt do you have freezing problems?


Reply to this

-
.

 Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

I have installed WDT 2.1.5 vía PPA... and I add repository for webkit (https://launchpad.net/~webkit-dteam/+archive/ppa) I don't know if the problem arise on the repository of webkit... but I think that no is it...

Thanks... for the response...


Tequilas Team - Made in Mexico!
Reply to this

-

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

Install following packages:

https://launchpad.net/~petrakis/+archive/wdt-main/+files/python-webkit_1.1.7-1%7Ekkwkt1_i386.deb
https://launchpad.net/~petrakis/+archive/wdt-main/+files/gir1.0-webkit-1.0_1.2.3-2%7Ekkwkt1_i386.deb
https://launchpad.net/~petrakis/+archive/wdt-main/+files/libwebkit-1.0-2_1.2.3-2%7Ekkwkt1_i386.deb
https://launchpad.net/~petrakis/+archive/wdt-main/+files/libwebkit-1.0-common_1.2.3-2%7Ekkwkt1_all.deb



-
.

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

Ready... All packages installed and the problem continue... Any other suggestion?


This application is great... I hope that the problem be can solve!


Tequilas Team - Made in Mexico!!

-

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

Ok I have removed one function from app, so we can do a little test. Donwload this file:
http://dl.dropbox.com/u/11001258/webdeveloper.py
now open as administrator /usr/share/wdt
and replace the webdeveloper.py with downloaded file.

I have removed one app, which can be a problematic, so we can do test right now



-
.

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

I sorry say, that the problem continue... I replace de file for the new download from dropbox link an the application behaviour were worst...


Thanks for help!... any other idea?


Tequilas Team - Made in Mexico!!

-

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 28 2010
 
Score 50%

Strange, I have encountered the same problem on my other computer and after changing the file, the freezing has been stopped. Never-mind, I will start to build fix release, in next 3 hour I will publish fixed version.



-
.

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 28 2010
 
Score 50%

That's great!!... Thanks for all... and I wait for the new release for test...

Te la rifas compa... (I don't know how to say in english that)


Tequilas Team - Made in Mexico!!

-
.

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Sep 30 2010
 
Score 50%

Hi... I'm sorry to Say that the problem with WDT continues... it is freeze is impossible working... works fine 10 or 15 seconds and hang up... I hope that a fix will be release but... but while it will release..

The migration to Maverick solve this problems?


Thanks...


Tequilas Team - Made in Mexico!!

-

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by petrakis on: Sep 30 2010
 
Score 63%

Sorry, but the the problem is individual. Perhaps higher version should work better (Higher Ubuntu). Also I am working on reducing of webkit threads , and this can maybe help also.



-
.

 Re: Re: Re: Re: Re: Re: Neither Works in Karmic

 
 by monsterdigital on: Oct 8 2010
 
Score 50%

Finally new version 2.2.5 solve the freeze problem... no more hang up...

Thanks...


Tequilas Team - Made in Mexico!!

-

 Doesn't work in Lucid 64bit

 
 by deflorator on: Oct 1 2010
 
Score 50%

When I try to launch the program I get the dialog: 'Your browser does not support the required features' and it just freezes so I have to force a shutdown.

This is the whole output from the terminal:

pawel@pawel-desktop:~$ wdt
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:52: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:53: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:54: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
** Message: console message: file:///usr/share/wdt/task/js/com.js @23: SECURITY_ERR: DOM Exception 18: An attempt was made to break through the security policy of the user agent.

** Message: console message: file:///usr/share/wdt/cssdesk/plugins.js @1735: SECURITY_ERR: DOM Exception 18: An attempt was made to break through the security policy of the user agent.

** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** Message: console message: file:///usr/share/wdt/cssdesk/desk.js @1: TypeError: Result of expression '$frame[0].contentWindow.document' [undefined] is not an object.

** Message: console message: @1: Unsafe JavaScript attempt to access frame with URL about:blank from frame with URL file:///usr/share/wdt/cssdesk/index.html. Domains, protocols and ports must match.


** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.1) (6b18-1.8.1-0ubuntu1)
OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:52: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:53: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/pawel/.themes/Clearlooks_Cairo-Coffee/gtk-2.0/gtkrc:54: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
/usr/share/wdt/webdeveloper.py:3163: Warning: g_source_remove: assertion `tag > 0' failed
gtk.main()
** (webdeveloper.py:1921): DEBUG: NP_Initialize
** (webdeveloper.py:1921): DEBUG: NP_Initialize succeeded
** Message: console message: http://jsbin.com/js/2.1.2/jsbin.js @174: jsbin init test

*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()


Reply to this

-

 Re: Doesn't work in Lucid 64bit

 
 by petrakis on: Oct 1 2010
 
Score 50%

which version of WDT you are using?


Reply to this

-

 Re: Doesn't work in Lucid 64bit

 
 by petrakis on: Oct 1 2010
 
Score 50%

It looks that you are using an old version, please update to latest version of WDT


Reply to this

-

 Re: Re: Doesn't work in Lucid 64bit

 
 by deflorator on: Oct 1 2010
 
Score 50%

I'm using version 2.1.5.


Reply to this

-

 Re: Re: Re: Doesn't work in Lucid 64bit

 
 by petrakis on: Oct 1 2010
 
Score 50%

The latest version is 2.1.9 and please update also your webkit and pywebkitgtk packages. All packages you can find in wdt repository


Reply to this

-

 Re: Re: Doesn't work in Lucid 64bit

 
 by deflorator on: Oct 1 2010
 
Score 50%

OK, so it seems it's not the newest version. I tried the newest .deb from Softpedia, but clearly that's not THE newest.
Thanks!


Reply to this

-

 Re: Re: Re: Doesn't work in Lucid 64bit

 
 by petrakis on: Oct 1 2010
 
Score 50%

Softpedia ???? Please use repository !!!!


Reply to this

-

 Re: Re: Re: Doesn't work in Lucid 64bit

 
 by petrakis on: Oct 1 2010
 
Score 50%

The best way to do all is to add a repository:

Quote:
sudo add-apt-repository ppa:petrakis/wdt-main


Quote:
sudo apt-get update && sudo apt-get upgrade


Reply to this

-

 Holy Cow

 
 by Zzzz on: Oct 3 2010
 
Score 50%

Everyday update, sometimes 2-3. Dude you are so smart that I am not sure what will happen next week.Please don't make this in 3D, please.

Zako




Reply to this

goto page: prev   1  2  3  4  5  6  7 

Add commentBack






-
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Artwork
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add Artwork
Public API
About GNOME-Look.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 GNOME-Look.org Team  
All rights reserved. GNOME-Look.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
GNOME and the foot logo are trademarks of the GNOME Foundation.